Error al desplegar Symfony en el servidor: PHP version «>= 8.0.0»

Tras desplegar un proyecto nuevo de Symfony en el servidor de producción me he encontrado con este problema:

Composer detected issues in your platform:

Your Composer dependencies require a PHP version ">= 8.0.0". You are running 7.3.29.

Tras verificar que la versión de PHP era la correcta, y tras dar algunas vueltas por el fichero composer.json para comprobar que todo estaba en orden, probamos a forzar al actualización de composer sobre el servidor. Mano de santo!

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('sha384', 'composer-setup.php') === '906a84df04cea2aa72f40b5f787e49f22d4c2f19492ac310e8cba5b96ac8b64115ac402c8cd292b8a03482574915d1a8') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Descargamos un composer.phar de la página oficial de Composer y ejecutamos una actualización sobre el proyecto:

php composer.phar update

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.